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Adding panels and toolbars
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Adding vector data
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Adding vector data
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Exploring attribute table

> Right click on the added

Layer i.e.

Afghanistan_Population
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Exploring atiribute table

Invert selection Organize column
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Select all D:select all iOpen field calculator
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13 13 Baghlan Mortheast 310724
14 14 Kunduz Mortheast 1010037 —
T show all Features _ 5 =




Exploring attribute table

Vector Raster Database Web Mesh Processing Help
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Changing color of vector data
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Changing color of vector data

5 Single symbol v

> Click on the Symbology tab  EEl | ... |
» Select Simple fill under Fill
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Changing color of vector data
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Changing color of vector data

» Click on the Symbology Tab p

ff Information

» Dropdown from Single
symbol fo Graduated

» Change the colors by
choosing from the Palette of

the color ramp -> click

Apply
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Changing color of vector data

Browser & )
LT HXO
'_.f‘»." Favorites

y [ Spatial Bookmarks
b [8] Home
» [ Gy
» [ DA
» [T EA
» LR\
» [ GA w
Layers (& )
M ® %W E~-F AL
v [l 256532 - 562536
v [] 562536 - 795262
v |:| 795262 - 1325659
v |:| 1325659 - 3562512
v . 3562512 - 6372977

Q. Type to locate {Ctrl+K) Coordinate| 71.56,20.13 | Scale 1:6694206 ¥ | [ Magnifier 100% % Rotatior |0.0° 4| V| Render &




Labelling vector data

> RighT CliCk On The Odded I_Oyer .QLayerProperties—Afghanistan_Pc:pulatiDn—Labels
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Labelling vector data
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Why Project the layer?

» To represent the curved surface of earth on a flat surface
» Coordinates are recorded in a Linear Unit i.e. meter

» Easy to understand and for calculations

* Please note for any analysis (raster/vector) all the layers must

have similar CRS



ProjectioninQGIS =+

> Click at the EPSG:4326 _Z&5 e e en S roei)

FiIterI L utm

Recently Used Coordinate Reference Systems

at the bottom right of QGIS

> In the Filter tab type UTM
> Select WGS/UTM zone 42N e

WGES 84 7 UTM zone 41N
WGESs 84 S UTM zone 415

Qnd Apply WGS 84 / UTM zone 42N

WGESs 84 S UTM zone 425
WIES 84 £ LIThA zrma AZKI

|

4
WGS 84 [ UTH zone 42N

WEKT
PROJCES["WES 24 f UTM zmone 42ZN™,
BASECEOECRS ["WES 24",
DATUM["World Geodetic System
lag4™,
ELLIEPSCID["WGS &84™,

(0.4

Authority 1D

Authority 10
EP5G:32641
EP5G:3274
EP5G:32642

EP5G:32742
FOSE-27A432

Cancel
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Projection in QGIS

> You will observe the changed CRS below in the display window

Before After

| Coordinate 326008,3253884 P Scale 1:6222380 ~ @@ Magnifier 100%
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) Save Vector Layer as...

Proj ecﬁo n in QG I S — 5h§3e‘1:u:se the folder and name Youlﬁil'

File name 3rt|ise 1\Exercise 1\Afghanistan_Province_UTM.shp ..

» Right click on the layer sy e _Solot T GRS oz Uy
Afghanistan_Population ->Export-> RS E|356:32542 - WGS 84 / UTM zone 42N |
Save Feature As 1o v T '

's‘ ge:a\opackage Layer CRS »| ted features
> Select CRS I i |0 export and their export options

) Properties...
Ml ™ Afghanistan Population SSeg

v [l 256532 - 562536
v [7] 562536 - 795262

» Give output file name as s s Automatic -

V! [] 1325659 - 3562512

v! Il 3562512 - 6372977

. . Force multi-type
Afghanistan_Province_UTM R

Save Selected Features As...

Save as Layer Definition File... [ 4 Extent [Cu rrent: n'ﬂnE]
Save as QGIS Layer Style File...

v Layer Options

v Add saved file to map | Cancel Help




Projection in QGIS

> Right click on layer ->Properties-> Information and observe the

Difference

(- Layer Properties — Afghanistan_Population — Information

Information from provider

Source
Symbology
Labels
Masks

3D View
Diagrams

Fields

Name Afghanistan_Population
Path orking Folders\2021'4
Current Systems & General Training

pril 2021\3. Capacity Building in

men GIT -June 2021\Day 1\Exercise

1\Afghanistan_Population.shp

Storage ESRI Shapefile

Comment

Encoding UTF-8

Geometry Polygon (MultiPolygon)

CRS EPS5G:4326 - WGS 84 - Geographic

Extent 60.4720833970000626,29.3770645360000344 :

74.8894511480000347,38.4907920760000550
Unit degrees
Feature count 34

Identification

a=
(abc]
N
¢

E

Attributes Form
Joins

Auxiliary Storage

Before

SR RO

Actions

Display
endering

Temporal

Variables

Identifier

Parent ldentifier

Title

Type dataset
Language

Abstract

Categories

Keywords

Extent

CRS
Spatial Extent
Temporal Extent

Style ~ OK Cancel Apply

Help

After

B ROy

(.} Layer Properties — Afghanistan_Population — Information

L
e Infarmation

Source
Symbology
€ Labels
€O Masks
3D View

Diagrams

N
L
]

lis

Attributes Form
Joins

Auxiliary Storage
Actions

Display

Rendering

Temporal

Variables

Information from provider

Name Afghanistan_Population

Path DAGIS_RSS Working Folders\2021\4. April 2021\3. Capacity Building in
Current Systems & General Training men GIT -June 2021'\Day 1\Exercise
1\Afghanistan_Population.shp

Storage ESRI Shapefile

Comment

Encoding UTF-8

Geometry Paolygon (MultiPolygon)

CRS EP5G:32642 - WGS 84 / UTM zone 42N - Projected

Extent 60.4720833970000626,29.3770645360000344 :

74.8894511480000347,38.4907920760000550
Unit meters
Feature count 34

Identification

Identifier

Parent Identifier

Title

Type dataset
Language

Abstract

Categories

Keywords

Extent

CRS
Spatial Extent CRS: - Projected

X Minimum: 0

Style = 0K Cancel Apply Help




Calculating area

»Load Afghanistan_Province UTM .shp
(you created on previous day)

» Click on Vector->Geometry Tools ->add
geomelry atiributes

»Select Input layer and CRS

» Dropdown and select Save to Fle

> Select the output folder and name your
fle as Afghanistan_Area_SqMeter

> Run

35 Plugins NElafeld Raster Database Web Pr

) & ﬂ') ﬁ Geoprocessing Tools )

Geometry Tools b

Analysis Tools

[ 3
Data Management Tools L4
»

Research Tools

%% Collect Geometries...
“P° Extract Vertices...

':53 Multipart to Singleparts...

W Simplify...

+/ Check Validity...

ﬂ Delaunay Triangulation...

3% Densify by Count...

....... Add Geometry Attribir
(P Lines to Polygons...
¢” Polygons to Lines...
B voronoi Polygons..

+) Add Geometry Attributes

Parameters | Log Add ge
Input layer . attribu
|a_.'.:.'= Afghanistan_Province_UTM ** [Egj] é\% | This algorit]

I | | properties ¢

S iR LS oo S input Layer layer. It gel

. with the sal
rﬂ:mw but with ad

Layer CRS 4 v attributes t

measureme

Added geom info Choose the projection
Lf'ixerc‘tae 1/Afghanistan_Area_SgMeter.shp € | .. rJ Depending

viervbor lsaoen

v Open output file after running algorit  Create Tempporary Layer

Save to File...
Choose the output folde™Z37eTo GeoPackage...

Save to Database Table...

Change File Encoding (Systel

0%

Run as Batch Process... | Run

e



Calculating area

File with added

geometry

Browser &I
- g
553 Capacity Building in Current Systemns 8 Gene =
- 5 Women GIT -June 2021
b [ Dayl
~ 5 Day2
¥ [ Exercise 1
v E Exercise 2
= KBL_Sentinel_2B.tif
" KBL_Sentinel_2B.tif.ovr
3 LandCover_Points.shp
P[] Day3
b [ Day4
b [ QGIS_Software (32 & 64 bit)
- FinalAgenda_WoGIT_Afghanistan_10_lunt
r B FinalAgenda_WoGIT_Afghanistan_10_Jung _

L] k¥

Layers £
£ -

v| [ | Afghanistan Area SqMeter

4, Type to locate (Cirl+K)

Added Area and Perimeter fields

(@] Afghanistan_Area_SgMeter — Features Total: 34, Filtered: 34, Selected

[ T o o T B L s 3 T A o I o S

= B B o e o S e
= | LA B M| = |

18

[ |
R

PROV 34 ID  PROV_34 NA ~
25 Zabul

26 Uruzgan
12 Takhar

31 Sari Pul

15 Samangan
3 Parwan

34 Panjsher

7 Paktya

29 Paktika

30 Nuristan
22 Nimroz

& Nangarhar
4 Maydan Wardak
5 Logar

9/ Laghman
14 Kunduz
10 Kunar

32 Khost

T show all Features _

g LT ES D
Province R  AFG_Popula
South 432561
South 452152
Northeast 1025123
MNorth 559577
Morth 387928
Center 664502
Center 371802
Southeast 795262
Southeast 652562
East 256532
South 356253
East 2352652
Center 751212
Center 458262
East 562536
Northeast 1010037
East 652452
Southeast 652352

area perimeter
1731602228... 860666.438...
1089312223... 745301.094...
1230797551... 703175.299...
1505893878... 804801.863..
1290517968... 612389.299...
5570585406... 522481.437..
3738790170... 381062.406...
5280219546... 462914.511...
1906962713... 831746.871...
8951473607... 633736.703..
4181116124... 1078084.53...
7364149636... 511498.983..
1059278145... 688314.532..
4383948617... 416867.599...
3929843284... 338400.348..
7949924194... 480082.304...
4863425793... 419101.778...
4288280600... 374629.839...

-

Toagles the editing state of the current layer

oordinate| 2393713294114 | %8 ocalk| 1:59733490 |~ | @ Aagnifie | 100%:

[+] Zota

M

—



Calculating area (Sq.Km) using field calculator

»Open Attribute Table -> Click
Toggle editing mode # | ->Open

0

Field Calculator [

»Give Output field name and type

»Select Geometry from the Row
number-> Sarea
»Type the expression

' Q Field Calculator

Only update 0 selected features

v Create a new field

Create virtual field

Update existing field

QOutput field name | Area (Sgkm
QOutput field type | Decimal number (real) A

F N

Output field length | 10 % Predsion |3 =

Expression Function Editor

=+ -]
$area /1000000

b . . . A

4

Q, Search... Show Help

F

row_number
Aggregates
Arrays

Color
Conditionals
Conversions
Date and Time
Fields and Values
Fuzzy Matching

3

General |

w

Output preview: 6022.007599402562

Geometry
angle_at vertex
$area

M
azimuth -
——



Calculating area

Browser (eS|
QRTHO
= 5 3. Capacity Building in Current Systems & Gene *
= 5 Women GIT -June 2021
¥ [ Day1
- 55 Day 2
b [ Exercise 1
bl E Exercise 2
o® KBL_Sentinel_2B.tif
»® KBL_Sentinel_2B tif.ovr
(= LandCover_Points.shp
v [ Day3
v [ Day4
¥ [ QGIS_Software (32 & 64 bit)
by FinalAgenda_WoGIT_Afghanistan_10_June
r B FinalAgenda_WoGIT_Afghanistan_10_June _

L L3
Layers [=ES]
« @ e T &~ A0

v| [l Afghanistan Area SqMeter

=

Q. Type to locate (Ctri+K)

Added new field

Q] Afghanistan_Area_SgMeter — Features Total: 34, Filtered: 34, Selected: 0

o= g LT E S D P E =&
PROV 34 ID PROV_34 NA  Province R~ AFG_Popula area perimeter

1 1) Kabul Center 6372977 4600785734.. 417311.765..
2 2 Kapisa Center 441010 1883764611... 239177.564..
3 3 Parwan Center 664502 5570585406... 522481.437..
4 4 Maydan Wa... Center 751212 1059278145... 688314.532..
5 5 Logar Center 458262 4383948617... 416867.599.,
6 b Ghazni Southeast 1828831 2175223208... 1023102.08..
7 7 Paktya Southeast 795262 5280219546... 462914.511..
8 8 Nangarhar  East 2352652 7364149636.. 511498.983..
9 Laghman East 562536 3929843284.. 338400.348..

10 10 Kunar East 652452 4863425793.. 419101.778..
11 11 Badakhshan  Northeast 950953 4343634983... 2059114.54..
12 12 Takhar Mortheast 1025123 1230797551... 703175.299..
13 13 Baghlan MNortheast 910784 1780935859... 771548.368..
14 14 Kunduz MNortheast 1010037 7949924194... 480082.304..
15 15 Samangan North 387928 1290517968.. 612389.299.,
16 16 Balkh Morth 1325659 1677797744... 838417.437..
17 17 Jawzjan MNorth 540255 1130463837.. 635203.819.
18 18 Faryab MNorth 998147 2051898268.. 923488.842.,

T Show All Features .

Area_SgKm

4600.78573...
1883.76461...
5570.58540...
10592.7814...
4383.94861...
21752.2320...
5280.21954...
7364.14963...
3929.84328...
4863.42579...
43436.3498..
12307.9755...
17809.3585...
7949.92419...
12905.1796...
16777.9774...
11304.6383...

' - O x
&l

Toaggles the editing state of the current layer

‘oordinate| 833676,3321556 % Scale 1:5573340  ~

& fagnifie | 100%

= | Rotatior (0.0°




Joining Atfiributes

> Click ¥
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Joining Atfiributes

(2 Layer Properties — Afghanistan_Pp— L
: | Q Add Vector Join >
Setting |}
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Source
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Joining Afiributes Joined field

() Afghanistan_Population — Features Total: 34, Filtered: 34, Selected: 0 — O X
SRR g T E S D
PROV_ 34 ID PROV_34 NA Province R AFG_Populal) AFG_Precipitation_lan-21 AFG_Precipitation_Feb-21 AFG_Precipitation_Mar-21 AFG_Precipitation_Apr-21 =
1 1! Kabul Center 6372879 7.51 21.51 115.27 49.48
2 2 Kapisa Center 44101@ 9.63 23.31 12038 4925
3 3 Parwan Center 664504 13.26 4213 151.25 7241
4 4 Maydan Wa... Center 751214 6.45 16.95 76.11 35.96
5 5 Logar Center 458264 7.90 25.73 95.26 48.27
6 6 Ghazni Southeast 1828831 6.25 11.30 4412 26.22
7 7 Paktya Southeast 795264 14.53 23.80 84.27 63.87
8 8 Nangarhar  East 2352654 13.83 26.13 103.39 73.81
9 9 Laghman East 562534 6.70 13.38 105.98 54.68
10 10 Kunar East 652458 19.70 17.22 145.10 7317
11 11 Badakhshan  Northeast 950953 9.25 20.95 136.99 33.10
12 12 Takhar Mortheast 1025123 15.51 26.65 200.91 72.84
13 13 Baghlan Northeast 910784 15.77 32.91 182.39 65.35
14 14 Kunduz Mortheast 101003§ 12.59 23.19 136.63 58.80
15 15 Samangan North 387929 20.59 46.79 137.53 3143
16 16 Balkh MNorth 1325659 12.05 27.55 75.27 12.04
17 17 Jawzjan Marth 540259 10.41 15.85 61.81 12.64
18 18 Faryab North 9981479 18.51 25.53 102.21 17.37
19 19 Badahis West 495954 16.93 34.49 83.01 16.05
20 21 Farah West 507400395 1309 ol Wi =
T Show Al Features _ E

Export the data as AFG_Precipitation_2021.shp
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